Tweak mode not working?

Whenever i try the tweak functionality i get a red bar and this in the console:

java.lang.ClassCastException: cannot be cast to

how can i fix this? tried deleting the processing folder and reinstalling. Nothing.
Have the android mode installed, extended code completion and the “getting strarted 2nd edition” examples…

Edit: Maybe the devs disabled it because of this

I can verify this problem on mac laptop. Version 3.3.5 still works in tweak mode (and perhaps later versions) if you’re looking for a quick fix.

I had the same problem when I was using 3.5.2, the latest version.
I “downgraded” to an older version, the 3.4 and it works.


Same, tweak mode only works in 3.4 not the newest version on my Mac.
And thanks for sharing the info, solved my problem!

How did you downgrade to 3.4? I tried downloading the earlier version but it does not include an exe.

You do not down grade in the literal sense (because this app/software does not install in the traditional way on Windows at least; you just unzip it).
You just download the older version (under the Stable Releases List) from the download page:
Unzip, replace or delete the version you had and open 3.4, that’s it.

Good luck :smiley: