Strange problem with an eclipse project and the Serial library

Hi guys, as the title said i have a problem!

I made an eclipse project with processing and the Serial library, on my windows 10 laptop everything works well and i have no problem. i tried to run the same project on my windows 10 PC (another machine) i have this exception when i call the static method Serial.list():

java.lang.UnsatisfiedLinkError: jssc.SerialNativeInterface.getSerialPortNames()[Ljava/lang/String;
at jssc.SerialNativeInterface.getSerialPortNames(Native Method)
at jssc.SerialPortList.getWindowsPortNames(
at jssc.SerialPortList.getPortNames(
at jssc.SerialPortList.getPortNames(
at processing.serial.Serial.list(Unknown Source)
at processing.MariellaSaysMain.setup(
at processing.core.PApplet.handleDraw(
at processing.awt.PSurfaceAWT$12.callDraw(
at processing.core.PSurfaceNone$

The strange thing is if i run the Serial write example from processing IDE everything works fine and works too if i export the application. The windows are both 64 bit version and i checked if eclipse run the code in 64 bit mode with this line of code: System.out.println(System.getProperty(“”) );

I post here the structure of the libs from eclipse view.

For now i discovered this, for any question i’m here.

How are you transferring the project from one computer to another?

By a github repository.