Processing 4.0b2 flashes splashscreen for a fraction of a second and exits; no error message, on Linux

Hello,

I’ve been using (and teaching) Processing for years. I’ve been using Processing 4 pretty much since it came out. This afternoon I was suddenly unable to start Processing. There are no error messages, it simply exits. Probably the last time I ran Processing was yesterday, and I have not updated or made any changes to my system since then.

I have tried removing and re-installing Processing. I have removed the entire .processing configuration directory.

Processing 3.5.4 works fine.

I start Processing from the command line. I see no messages or errors in my terminal or in syslog.

Any suggestions?

Is there a way to run Processing in a more verbose way to get some indication of where it’s having trouble? I’m afraid that I don’t know much about Java.

Processing:
processing-4.0b2

OS:
uname -a Linux tx1g83 5.11.0-37-generic #41-Ubuntu SMP Mon Sep 20 16:39:20 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=21.04
DISTRIB_CODENAME=hirsute
DISTRIB_DESCRIPTION=“Ubuntu 21.04”

Java:
$ java -version
openjdk version “11.0.11” 2021-04-20
OpenJDK Runtime Environment (build 11.0.11+9-Ubuntu-0ubuntu2)
OpenJDK 64-Bit Server VM (build 11.0.11+9-Ubuntu-0ubuntu2, mixed mode, sharing)

1 Like

Hi! Welcome to the forum!

I have no idea but it may help if you post an issue on github if you haven’t - the code contributors might not checking this forum often.

1 Like

That’s a great suggestion @micuat, thank you, I will do that

This unfortunately doesn’t help you, but it does work for me with the same OS. Java is different

$ java -version
openjdk version "14.0.2" 2020-07-14
OpenJDK Runtime Environment (build 14.0.2+12-Ubuntu-1)
OpenJDK 64-Bit Server VM (build 14.0.2+12-Ubuntu-1, mixed mode, sharing)

but afaik the java version doesn’t matter, or? Doesn’t Processing come with it’s own java?

I tried both 4.0b1 and 4.0b2. Using Nvidia 460 drivers.

Does it show any error if you start it from the command line?

1 Like

Hi @hamoid, thanks for the suggestion. I forgot to write that I do start Processing from the command line and no, there are no error messages there.

Good question about the video drivers: My laptop (Thinkpad X1) has only Intel graphics.

Did you remove the right config folder? .config/processing/preferences.txt

1 Like

That solved it! Thanks!
You are correct, I had removed .processing/* but I didn’t think to check in my .config directory.

Still curious as to what changed, I don’t recall making any changes to my preferences. If it happens again I’ll compare files carefully.

1 Like