Processing 3.5.4 not opening

I just downloaded Processing again and wanted to launch some of my old programs I coded together with CodingTrain. Whenever I try to open Processing ,or any file related to it, nothing happens (“processing.exe” shows up in TaskManager and disapears shortly after)! I already tried running it as administrator and re-downloading which sadly didn’t help.
Am I missing something obvious?

I don’t know if this will help, but maybe try reinstalling the latest version of java if you haven’t done so already, and make sure you’re downloading the correct version of processing for your operating system (The 64bit windows version might not work if you’re using a 32bit machine).

1 Like

I reinstalled java and already have the correct version for my system, but still nothing happens sadly. But good idea atleast

Processing rather annoyingly in my view installs its own version of java, so unless you are coding outside of processing ide the installed java on your own machine has zero influence.

1 Like

That is the recommended way of using Java for some time now. Processing may have been ahead of the curve there.

You can always replace the JDK in the install directory with another JDK 8 version.

So you mean I can copy the Java folder (C:\Program Files\Java\jre1.8.0_281) into the processing’s java folder (C:\Users[…]\processing-3.5.4\java)?

Yes, well just rename the existing one and then copy the new one in at the same name. Just make sure the relative file names match up. On Linux I just symlink rather than copy.

Well I did that now and it still doesn’t work for some reason.

This is my processing’s java folder now btw, am I missing something?

still ain’t working btw

I wonder if you’ve found a solution? I ran into the same issue today.