P2D, P3D only show grey screen -- until java window is closed

When I’m trying to use P2D or P3D rendering, only a blank, grey screen is shown.

This is the simplest code I could come up with to illustrate the problem:

size(200, 200, P2D);

Expected output is a black background, but instead, there is a grey one:
Grey Screen

When I close the sketch (using the ‘x’ button (which is in red in the above screenshot)), the correct output flashes in the fraction of a second before the window closes.

This is happening in any sketch where I use P2D or P3D instead of the default renderer.

I’m using Processing 3.5.4 (on macOS 12.2.3, if that is somehow relevant). I’ve tried unistalling/reinstalling processing (as well as restarting my machine).

Is anyone else having this problem? I would appreciate any advice.

I was thinking about opening an issue on github for this, but I want to make sure it is actually a problem, and not something that is just a problem on my end.

1 Like

Hi! That sounds strange. Did the code work as expected before? Did the OS upgrade recently?

I wonder if this is related to the similar issue discussed in Problems with P2D and P3D renderers with new Apple M1 processor ? Maybe try the frameRate(..) “fix” if you haven’t.

1 Like

Did you mean mac OS 11.2.3 ??

This worked. Thank you! Sorry that I missed that thread when looking earlier!

1 Like

And yes, I did mean 11.2.3. A quote for context from the other thread (for the convenience of people finding this in the future).

Thank you for the clarification. Adding the frameRate(xx); command to “setup” should help you test/run this sketch in the IDE but if you experience is similar to mine, you will not be able to export an app that runs. I haven’t spent much time trying to resolve this issue and until they release a version of Processing that is compatible with OS 11.x.x, it may remain a problem.

Is there any news regarding this topic?
Has anyone exported an functional P3D app for / on a M1 processor?

Best Philipp


I have not been working with Processing since I got the new Mac - partly because of this problem. I have been working with C++ and OpenFrameworks… but was recently informed that there is a beta version of Processing in development that is intended to support the M1 processor. Eventually I will do more with Processing so I hope that is the case!