Migrated Processing to new MacBook Pro - OSX 11.1 - sketches fail

Still no responses - but I have discovered that the problem/failure indicated below appears to be the result of using either the P2D or P3D renderers. When using the default (i.e. no renderer indicated), sketches function properly.

So it appears as if the question now is, what are the issues associated with using either the P2D or P3D renderer and the OSX 11.1???

Thanks for any input since some of my sketches require the 3D graphics capabilities of Processing.

This has been posted for 24 hrs… and read by 20+ people, with no responses… even if you don’t know what may be causing this, if you have a MacBook Pro running OSX 11.1 with the Apple M1 chip and the Processing IDE works for you - just let me know. PLEASE

Just purchased a new MacBook Pro running OSX 11.1 and migrated the content from an older MacBook. I have been developing sketches for years and migrated the sketch folders and a number of exported apps.

I checked out the performance on the new computer of the exported apps. They run correctly and very quickly - which is nice, BUT, when I tried to open a sketch for an app that does run, the sketch doesn’t launch and I get the following error message in the console:

0   AppKit                              0x00007fff22c408bf -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 352
1   AppKit                              0x00007fff22c2b561 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1375
2   AppKit                              0x00007fff22c2affb -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
3   libnativewindow_macosx.jnilib       0x000000012eed03fe Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
4   ???                                 0x00000001136d84c8 0x0 + 4620911816


I reinstalled the most current version of the Processing IDE for the Mac and made sure Java was current… Restarted the computer … and still no luck with running the sketch! Tried to run a sketch from the IDE Examples folder, same problem…??

Any suggestions for a solution will be appreciated.

Hey there

As I understand it this got addressed…

But sadly not for exported applications.
Do you know anything new?

I hope this gets addressed soon…