No toolchains for mips64el-linux-android


#1

I’ve been upgrading various things recently, including Android Studio and Processing and Processing for Android.

And now I can’t compile sketches for Android in the Processing IDE anymore.

I’m getting this error message :

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app'.
> No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

* Get more help at https://help.gradle.org

This https://github.com/google/filament/issues/15 seems to suggest that this option for the NDK is deprecated. But that gradle needs to be updated to remove references to it.

I’ve tried to upgrade everything I know about. And I’m not calling the NDK from this Processing sketch, but maybe something behind the scenes is.

I’m using these in my sketch :

import android.media.AudioManager;
import android.media.SoundPool;
import android.content.Context;
import android.app.Activity;
import android.os.Build;
import android.content.res.AssetFileDescriptor;

OTOH, I have the same error message with a minimal program that uses no extra libraries.

Is this something that needs to be fixed / updated in the Android Mode for Processing?

A month or so ago the same sketch was compiling, installing and running on Android fine.


#2

@interstar===

  • what android studio version?
  • what graddle plugin version?
  • is ndk installed?
  • what version of ndk?
  • when you go to the sdk manager (with AS) is ndk checked?

Problem and solution relies on these infos!


#3

Android Studio 3.2.1

Android SDK (as appears in the Processing window SDK Build Tools 26.0.2

How do I check the gradle plugin version that Processing is using? The most recent number referenced in my .gradle directory seems to be 4.6

NDK is installed. (Checked in the SDK manager). Says version 18.1.5063045 (the latest updated via Android Studio)


#4

@interstar
ok; your NDK is too recent and does not contains the folder required by gradle (i am quite sure that your version number is wrong); so if you really want to work with NDK you have to download an older version (i think that the last one which was ok with gradle was 16, or 17, but let us say 16); after that you can create (if it s not) the folder required in the SDK. Of course if you dont need NDK, you can also uninstall it from the SDK manager (with AS)…


#5

What I don’t understand is why my NDK number is important for Processing. I’m not using NDK in the processing sketch. I even made a minimal sketch that does nothing but draw a rectangle on the screen and got the same error.

I do want to use NDK from another project (nothing to do with Processing) which is why it’s installed in AS. But why should Gradle care about that at this point?

Can’t the SDK ignore stuff that isn’t being used for a particular project? Or does everything have to be broken if one thing is?

Also, from the other link I gave, it sounds like mips64el-linux-android is getting deprecated. Presumably that’s why it’s been removed from NDK 18.

In which case, shouldn’t it be possible to tell Gradle not to look for it? Rather than rewind NDK to an earlier version? Is this the fault of Gradle itself? Or some local config-file that Gradle is looking at which I could edit myself?

cheers

Phil


#6

OK.

I tried removing the NDK from my system, and it’s worked. So that’s a temporary fix.

cheers @akenaton


#7

@interstar===
gradle has probably to update soon…and when it’s done you can reinstall ndk…till next problem!