My camera is not working

I use processing 3.5.3 on windows7. I launched capture sketch. My camera is recognized in console but no image appeared… Where is the problem?

If this is the unchanged default capture sketch, this is fine, but if you have custom code please post it as formatted text – not a screenshot.

Did you try changing “cameras[12]” in your capture sketch to one of the cameras in your list, like [0], [1], or [2]?

Thanks for your response. Yes this is default capture sketch. i tried [0], [1]…without success. On the other side I tried with my raspsberry (GLvideo), and the camera works perfectly. Problems with Video (Gstreamed based video with processing) on Windows7

I’m not sure!

In the screenshot the visible camera listings all say “USB2.0 PC CAMERA” – what is the actual make/model of the camera, and is it USB-connected or built-in?

This is a USB camera. In fact in the console, appear 2 cameras: USB2.0 PC CAMERA and my internal one:
name=Integrated Webcam, size=320x204,fps=30 for example.
If I choose that one instead of the USB one, its led turns on but still no image

I have been struggling with the same problem since 2016.
Camera is recognized by processing in list , but will not grab, in loop i get no video detected.
I have tryed several camerfas. !. the integrated lenova laptop camera works ok
2. A camera that shows up under Imageing Devices in Device manager works fine.
3. Any camera or camera device that shows up in Device Manager under Sound and game controllers as a video device or as anything else does not work, even though processing does see it as a video device.
The problem is clearly in the video library.
Can anyone fix this so it works with plugged in USB cameras?!
Note: any camera input works with 3rd party software OK, so it is not a system problem.
If the 3rd party grabbers work so should Processing.


Try Video library v2 beta from GitHub, or PraxisLIVE.