Mac OS Catalina won't open exported applications

I have a couple of Processing applications exported with embedded java from Processing 3.5.4 on a Mac. I upload these in a zip file to a website for users to download on their Macs. Unfortunately on Mac OS Catalina, double clicking on the application gives an error “The application xxxxx cannot be opened”. No further explanation, and when I click the ‘?’ in the dialog box for help, the help window that opens is just blank!

I have been able to get the same apps to run on the Mac if I access a copy on my local Windows 10 Network shared folder.

Has anyone experienced a similar issue and, hopefully found a workaround?

I did try using Terminal to disable the protection using

sudo spctl --master-disable

and whilst this does enable the Allow apps downloaded from “Anywhere” option in Security & Privacy, I still get the same ‘unable to open’ error.

Thanks, Phil.

Did you try right clicking on the app and choose open ?
You might get a confirmation panel asking if that’s what you intend to do the first time.

Yes, I did, same outcome alas. Catalina seems to have locked everything down :crazy_face:

Yeah Gatekeeper is doing a good job :slight_smile:

Have you tried allowing apps from anywhere in the Security and Privacy preference panel directly?

(If you issue sudo spctl --master-disable with preferences running I don’t think it works)

I’ll try again but the sudo spctl --master-disable command is required to make the ‘Anywhere’ option visible. It does become visible and I select it but I still get the ‘can’t open’ error.

Thanks for your suggestions :slight_smile:

Try notarizing it?

See Notarizing exported application on macOS 10.15 (Catalina)