Processing won't open on Mac

Hello, I’ve been using Processing since last year and some days ago I installed the latest version. It worked but today I tried opening it again and the window opens for a brief moment but then disappears. I tried deleting it and installing older versions but it doesn’t work. I have a MacBookPro with Apple M1 Chip and macOS Monterey (12.6). Can anyone help me?

Hi Oli1,

i ve same configuration, m1 monterey and everything is fine
if you downloaded a fresh processing it s strange, i will check security , mine have “full disk acess” and “camera” etc…
otherwise i will open mac “console”, launch processing, you re supposed to see in “console” why the software closed
something else you can try too, right click the app, show package content , in “content/macos” double click processing, it will open processing via a terminal then may be will be printed there some intel why it fail

Hi, I’ve tried everything that you told me but it didn’t work. i tried to see in console why the software closed but there wasn’t any message. It still won’t open and the last time I tried it said that the file was damaged.

I’ve also noticed that usually when you download Processing you have a folder with tools and libraries etc, but everytime I tried downloading it there wasn’t any folder.

Did you try running the executable in the App bundle? Looks like this:

Screen Shot 2023-02-20 at 2.33.11 PM

There should be a report of what happened in the Terminal window.

If you get a message that says that it’s damaged, try going to AppleMenu/SystemPreferences/Security&Privacy and there should be a dialog there where you can request that the app be opened anyway.

1 Like

Hi, very strange,
for the last try: “right click the app, show package content , in “content/macos” double click processing, it will open processing via a terminal then, may be, will be printed there some intel why it fail”
When you double click processing icon, do you see a terminal app window opening? do the processing icon inside this directory looks like in svan message?

Hi Guys,
I got the same Problem.
I’m using a 2015 MacBook Pro with OSX Mojave Version 10.14.6 and Processing 3.5.4 .
They should be compatible from my research. When i run the exec the Terminal gives me this:

           /Applications/ ; exit;

          Gregors-MacBook-Pro:~ gregor.k$ 
          /Applications/ ; exit;


         Saving session...

         ...copying shared history...

         ...saving history...truncating history files...


         Deleting expired sessions...7 completed.

I don’t even got a clue what’s the Problem and how to fix.
I would appreciate any kind of help.