[Linux] Unable to run - files and directories not found for java?

I’m using Arch Linux, using i3wm if it makes a difference. I’ve downloaded Processing as I’m using it for a project on my Windows machine and would like to continue development on my Arch Installation.
I downloaded and ran the Processing package from the AUR, making sure linux was up to date. Processing launches, but when I run a series of errors occurs, which say they’re caused by (the full error is too long to paste here):

Caused by: java.io.IOException: Cannot run program “/usr/lib/jvm/java-8-openjdk/bin/java”: error=2, No such file or directory


Caused by: java.io.IOException: error=2, No such file or directory

I mean I can confirm Processing is correct - those files/directories do not exist. But I have a full Java installation (I’m not sure where it’s been placed, I simply used pacman to install it). How should I go about fixing this?

Also: I’ve downloaded the tgz from the website, and I’m not even sure how to go about installing it, so if that’s an available fix, some help would be greatly appreciated.


1 Like

You should read the entry by myself and xyproto on issues re openjdk and archlinux in response to malan88. Essentially you need to install jdk8 and use archlinux-java to make that the default version.

1 Like

Worked perfectly! Thanks a lot for the fix, saved me potential hours of internet scouring.

PDE’s incompatibility w/ any Java version past 8 attacks again: :stuck_out_tongue_winking_eye: