Installing Processing on Ubuntu

I downloaded Processing for Linux and the one for Mac but both came up with error messages when I open the program icon processing

#!/bin/sh

# This script runs Processing, using the JRE in the Processing
# installation directory.

# If your system needs a different version of Java than what's included
# in the download, replace the 'java' folder with the contents of a new
# OpenJDK (Java 11 only), or create a symlink named "java" in the
# Processing installation directory that points to the JRE home directory.

# Thanks to Ferdinand Kasper for this build script. [fry]


# JARs required from JDK (anywhere in/below the JDK home directory)
JDKLIBS="rt.jar"

# Set this to non-zero for logging
LOGGING=0

# Logs name and value of a variable to stdout if LOGGING is non-zero.
# Expects the variable name as parameter $1.
log() {
  if [ $LOGGING -ne 0 ]; then
    eval echo $1=\$$1
  fi
}


# Locates JDKLIBS in a directory and its subdirectories and saves their
# absolute paths as list to JDKCP. Expects the directory as parameter $1.
# Sets SUCCESS to 1 if all libraries were found, to 0 otherwise.
make_jdkcp() {
  # Back out of JRE directory if apparently located inside a JDK
  if [ -f "$1/../bin/java" ]; then
    DIR="$1/.."
  else
    DIR="$1"
  fi
  log DIR

  JDKCP=
  SUCCESS=1

  # Locate JDKLIBS
  for L in $JDKLIBS; do
    # Locate only the first library with a matching name
    LIB=`find "$DIR" -name $L 2>/dev/null | head -n 1`
    log L
    log LIB

    # Library found?
    if [ -n "$LIB" ]; then
      JDKCP="$JDKCP"${JDKCP:+:}"$LIB"
    else
      SUCCESS=0
    fi
  done

  log JDKCP
}


# Get absolute path of directory where this script is located
APPDIR=`readlink -f "$0"`
APPDIR=`dirname "$APPDIR"`
log APPDIR

# Try using a local JDK from the same directory as this script
JDKDIR=`readlink -f "$APPDIR/java"`
make_jdkcp "$JDKDIR"
log SUCCESS

# Don't use the installed JDK, because it's not supported.
# Local JDK found?
#if [ $SUCCESS -ne 1 ]; then
#  # No, try using the preferred system JRE/JDK (if any)
#  JDKDIR=`which java` && JDKDIR=`readlink -e "$JDKDIR"` && JDKDIR=`dirname "$JDKDIR"`/..
#  make_jdkcp "$JDKDIR"
#  log SUCCESS
#fi

# Add all required JARs to CLASSPATH
CLASSPATH="$CLASSPATH"${CLASSPATH:+:}"$JDKCP"
for LIB in "$APPDIR"/lib/*.jar; do
  CLASSPATH="$CLASSPATH"${CLASSPATH:+:}"$LIB"
done
for LIB in "$APPDIR"/core/library/*.jar; do
  CLASSPATH="$CLASSPATH"${CLASSPATH:+:}"$LIB"
done
for LIB in "$APPDIR"/modes/java/mode/*.jar; do
  CLASSPATH="$CLASSPATH"${CLASSPATH:+:}"$LIB"
done
export CLASSPATH
log CLASSPATH

# Make all JDK binaries available in PATH
export PATH="$JDKDIR/bin":"$PATH"
log PATH

current_name=`basename $0`
cmd_name='processing-java'

if [ $current_name = $cmd_name ]
then
    java -Djna.nosys=true -Xmx512m processing.mode.java.Commander "$@"
    exit $?
else
  # Start Processing in the same directory as this script
  cd "$APPDIR"
  java -Djna.nosys=true -Dawt.useSystemAAFontSettings=on -Dswing.aatext=true -Dpython.console.encoding=UTF-8 -Xmx512m --add-opens=java.desktop/sun.awt.X11=ALL-UNNAMED processing.app.ui.Splash "$@" &
fi

Hi @chrissatch,

Welcome to the forum! :wink:

Can you please format the error message with the </> button or use backticks around it like this: ```code``` → code

It seems that you posted the content of the bash script, is it what you wanted to do?

Yes, I am just learning programming I put in the <>

But I am taking a college level Processing course, and thought it would be easier to have Ubuntu but then I have been having trouble installing Processing the way it says from the instructions on the website. Is there a way to open it in terminal? Or is there any way that is easier because I don’t know what they mean by symlink and creating a new java folder in the bash script?

No problem! (just edit your message :wink: )

Yes I am myself running on Linux for everyday tasks and programming and you learn a lot by doing so!

The installation process should be straightforward, just run the .sh script from the command line:

$ cd processing-4.0.1 # Go into the processing folder
$ sh ./install.sh # Run the install script

Then it will install Processing and add a menu shortcut in your applications.

You can also directly run it from the command line with:

$ ./processing

Notes:

  • You can also run the install script without calling the sh shell program like so: ./install.sh
    This is possible because the file is executable:

    $ file install.sh
      install.sh: POSIX shell script, ASCII text executable
    

    And it contains a Shebang at the top of the file telling the operating system which interpreter it should use:

    $ head -n 1 install.sh
      #!/bin/sh
    
2 Likes

I did it in the terminal bu when I ran

< $ ./processing>

an error message ran saying:

./processing: 110: java: Exec format error

Hey josephh,

I got it running!! So happy, I was working on labs for my class in the web editor, but in the regular program I can do so much more with it!!!

1 Like

Thank you very much, when I ran it through the terminal it loaded!

1 Like