Issue with Intel RealSense Camera and Processing "Failed to Set Power State"

IMHO the Intel RealSense D400 series cameras are the new Kinect.

However, today, after unboxing the camera from last year, it no longer works… See screenshot.

I see an error message after trying out the examples sketches for the Intel RealSense Processing library and I get the following error:

“Failed to set power state”

I have never seen this error before and although there are some searches online for it I am drawing a blank as to how to fix it.

My hunch is that it’s something simple. I recall a bunch of Processing Textbook examples no longer worked until I added frameRate(30) in setup so maybe it’s something like that? (I already tried that of course and no change).

Of course I also restarted the computer, tried different cables, USB ports, and all that with no success. In fact I am using the same computer, version of Processing, and library version so I am honestly not sure what would have changed?

Thanks for any tips and help!

Just found this issue on the GitHub. Looks like it’s a possible issue from upgrading to OS 12.6 Monterey. Nice…

1 Like

Hi

Did you find a solution? I’m o OSX 13.0 and getting the same issue with the Realsense D457.

Intel stopped supporting MacOS from HighSierra on. It‘s because they would need to write a new kind of driver for the newer MacOS‘s and it‘s not just a trivial thing.

I would recommend Luxonis cameras today. There is also a Java wrapper for the C++ library. Someone would need to port it to Processing :slight_smile: