How to use Processing on 4k displays?

I am using Processing in WSL/Ubuntu with X410 server.
It works, but the text and the menus are tiny, tiny, I can barely read. How can I adjust the menu and the text?

Hi! Do you mean texts and menus inside or outside Processing?

For Processing there’s things like textSize(). Libraries like controlP5 let you set the font and font size… it depends on how you are drawing texts and menus…

The text and menus. It’s a matter of scaling.!AoGfVTw1lQbXkxA-OYG4029j5qQT

I see! You mean that the texts and menus in the Processing IDE are tiny (I thought maybe you mean the text you are drawing is too small).

I see this bug in GitHub:

But it is marked as “cantfix”. Maybe you can add a screenshot to that issue and explain that other windows have correct text size in their menus, but the Processing IDE has much smaller text for some reason.

You could also try if this affects Java programs in general, or only Processing.

Ok. I’ll stop using Processing. I just wanted to give it a try.


@codrutp it just may be the processing editor that’s the issue with scaling and might be a bug that I’m sure the developers will fix . I’m assuming you played around with your display settings on your monitor already correct ? or tried a different IDE ?

@codrutp i see you like to work in browser,

You should be able to change the interface scale in preferences:


@Jakub Thank you! Much better! But still not perfect!AoGfVTw1lQbXkxWkojtoaTsxwEfe
However, I guess there is not much which can be done anymore.
Thank you, anyway!

I think there is something wrong, it should not look like this. Could you please tell me what is your desktop environment / window manager?

I am not using a window manager. Just Microsoft’s WSL with Ubuntu 18.04 and the display exported to which is redirecting to X410 (from Microsoft Store) as an X Server. It’s a very convenient way to run Linux apps without installing Linux.
Yes, I know, I am doing this just because I can. Probably if I would run Processing for Windows it would be correct with this scaling option. I’ll give Windows version a try.