Editing window Cursor out of register Windows 10

please format code with </> button * homework policy * asking questions
Not sure if this is the right place to report this. But for me it’s an app-killer problem for Processing 4 on Windows 10, and am surprised more haven’t flagged it up.

The insertion point of the text cursor in the code-editing window is off. So the cursor shows blinking at a particular point on a line, but if you insert of delete text this happen a number of chars to the left of the blinking cursor. It gets worse with long lines of text, so is OK on the very left hand side or a line, but is about 10 chars out on a long line.
A student of mine has just tried it on his laptop and has the same problem. It make the system unusable. Tried changing font to monospace, automatic scaling etc in preferences but the problem persists.

More info please, what version of p5 are you using, new install?

Hi Paul

It’s the Java-based processing desktop app for PC. Processing 4.0b2-windows 64. Running on Windows 10.

best wishes


Have you checked processing github to see if there are similar issues.

Do previous versions produce the same error and have you tried a clean install.

All else fails i would try an alternative ide. I know its not the ideal solution…

it’s to do with windows scaling. you can read more here

1 Like

Yes, changing Display Settings → Scale and Layout to 100% (was 150% recommended) fixed it. Thanks Hotfooted. But now all my apps have reallllly small UI elements. Not what I would have chosen, so this is a work-around in my book. Think it still needs a fix in the short term.