How to use Processing-4 in Visual Studio Code

Hello,
On windows 10 I have been trying to run Processing 4 on VSCode for a few days & getting nowhere. Processing-4 app running stand alone works OK on a test.pde file but running the same code in the Processing Language on VSCode doesn’t work after following the path/alternative instruction of the extension due to issues with the path definitions I guess. The steps I’ve done thus far

  1. Installed Processing-4 on USB, ran the app loaded and ran test.pde file OK. So Processing-4 works in stand alone mode (see screen dump)

  2. Installed Processing Language extension into VSCode (which works well with C++, python & arduino). I can write pde files on VSC which won’t run in VSC but can be saved and will run with Processing -4 on my USB.

  3. Applying both the “Add Processing to path” and the “Alternate Method” detailed in the Processing Language extension instructions (one then the other) resulted in either nothing happening or the errors below.

  4. Created Task File and changed “command”: “${config:processing.path}” to “command”: “N:\ Processing\processing-java” as suggested in YouTube Tony Manzana's Install Processing In VS Code - YouTube

  5. Note that using “processing.path”: “N:\Processing\processing-java}” as suggested in the extension details didn’t work caused the error; “Property processin.path is not allowed”.

  6. Running Test.pde creates the error show in 3 above saying the path doesn’t exist I think. But the path is as fin the insert above is correct ie “N:\Processing\processing-java” (unless I’ve misunderstood the meaning of PATH)

There seems to be something wrong with the path details or its being modified somewhere I guess by VSC perhaps I don’t know what it is, and I can’t find any reference to a similar problems. I must be one of thousands who have the same/similar problems, many may have just give up, for those that haven’t and myself would appriaiate any help.

Regards
DMac

PS
I tried using Processing-3.5.4 which resulted in :
" > Executing task: N:\Processing\processing-java /property:GenerateFullPaths=true /t:build /consoleloggerparameters:NoSummary <
Command line edition for Processing 1283 (Java Mode)
–help Show this help text. Congratulations.
–sketch= Specify the sketch folder (required)
–output= Specify the output folder (optional and
cannot be the same as the sketch folder.)
–force The sketch will not build if the output
folder already exists, because the contents
will be replaced. This option erases the
folder first. Use with extreme caution!
–build Preprocess and compile a sketch into .class files.
–run Preprocess, compile, and run a sketch.
–present Preprocess, compile, and run a sketch in presentation mode.
–export Export an application.
–variant Specify the platform and architecture (Export only).
–no-java Do not embed Java.
Starting with 4.0, the --platform option has been removed
because of the variety of platforms and architectures now available.
Use the --variant option instead, for instance:
variant platform


macos-x86_64 macOS (Intel 64-bit)
macos-aarch64 macOS (Apple Silicon)
windows-amd64 Windows (Intel 64-bit)
linux-amd64 Linux (Intel 64-bit)
linux-arm Linux (Raspberry Pi 32-bit)
linux-aarch64 Linux (Raspberry Pi 64-bit)
The --build, --run, --present, or --export must be the final parameter
passed to Processing. Arguments passed following one of those four will
be passed through to the sketch itself, and therefore available to the
sketch via the ‘args’ field. To pass options understood by PApplet.main(),
write a custom main() method so that the preprocessor does not add one.

I don’t know anything about /property:GenerateFullPaths=true.
The terminal process “C:\WINDOWS\System32\WindowsPowerShell\v1.0\powershell.exe -Command N:\Processing\processing-java /property:GenerateFullPaths=true /t:build /consoleloggerparameters:NoSummary” terminated with exit code: 1.
Terminal will be reused by tasks, press any key to close it. I would appreciate any help "

I have solved this issue after playing around. In task.json file changed entry

"command": "N:\\Processing\\processing-java",

to

"command": "N:\\Processing\\processing-java.exe"

and now displays Processing window on Shift / Ctrl / b. Why no idea.

Hopefully may help someone else.

1 Like

Hi there, thanks, i tried all the above and i still get a problem.

The out\source generates ok, but i get no ‘run window’, or sketch output appearing. The only response is ‘terminated with exit code: 1.’

running processing-java --help from the command line in the shell works, so I think I am past the path challenge… any thoughts?