Gl video present view on PI

Hello!

This is my first time posting on here and using processing with a raspberry pi. I have got my video playing with glvideo but I would like to use the present tool to show it. However it doesn’t seem to work with my sketch or the example sketches. They just don’t load the video at all, some show a blank screen and sometimes they flash black and white. Any suggestions? Thanks!

Update: I got the present view to play by increasing my GPU to 80 in the raspberry pi configurations.

Does anyone know how to hide the top menu bar in present view? There is also a small stop button in the bottom right corner. I just want it to be black except for the video playing.

Thanks!

1 Like

hi,
thanks for the “repair” info, but it is a little bit cryptic?
RPI terminal:
sudo raspi-config
/ 7 Advanced Options
/ A3 Memory Split
/ MB for GPU set: from 64 to 128


now to your question?

you use the Processing IDE 3.5.3 ( for Raspberry Pi )?


if you talk about p5js.org online editor in the Chrome browser of RPI
that has a present mode
https://editor.p5js.org/kll/present/7ZIWNamQk ( use mouse click )
( the /full/ screen version seems to be currently damaged? )
and when you press F11 browser goes fullscreeen ( for canvas to that need some more code )

but that has actually noting to with RPI?


more exact description is required.

1 Like

Thanks for the reply! To be clearer the present mode I am talking about is found by selecting “sketch” and then “present” from the drop down menu.

Anyway just thought I would update again for anyone else who might of had this problem. I was able to get the top menu bar of the raspberry pi to stop showing in present mode by changing the raspberry pi settings directly:

Right-click on the raspberry pi taskbar and select “Panel Settings”. Click on the “Advanced” tab, and check “Minimize panel when not in use”.

2 Likes