Pi 4, buster and GLvideo demise

Hi all,

So unfortunately the glvideo library is broken with buster and pi4, and is no longer being developed or supported by gohai. Does anyone know if the is plans to make the processing video library compatible? Or do we have any other options for playback?

Is the Processing for Pi side of things going to continue? Or is it winding down also?

Have you tried the v2 betas of the Processing Video library on the Pi? The underlying GStreamer bindings should work. Of course, without the hardware accelerated link to the Processing OpenGL pipeline at present.


Oh nice, didn’t see that. Will make a fresh image and give it a go/report back

Hi there!
I’m having the same issue with the glvideo library on the Pi4 (and weirdly I’m also a Steve J haha)
Just curious did you switch from using the GLvideo library to just the Processing Video library (beta v2) to get it working?

here tested only RPI3B+ but
https://github.com/processing/processing-video/releases/tag/r6-v2.0-beta4 ,
works on
RPI buster image 2019-09-26

for video , USB cam , RPI cam

currently from contribution manager can not use:
– video
– sound
– glvideo
for newest RPI image

1 Like

I can confirm @kll observations with PI 3, however on PI 4 video capture doesn’t seem to work for me. My usb camera gets detected (the led light comes on) but no video displayed.

1 Like

Try Version Version 1.2.2 or 1.2.3 from gohais repository (see releases). It is very sad that this isn’t supported any longer. Cause I’m also struggeling with h264 decoding in Processiing and Raspberry.
Cause GLVideo decode Tello camera streams via udp straight forward. I’m still on Raspberry 3B+


so you still could use the old image ( DEBIAN stretch and Processing 3.4 ? GLVideo installed?)

It is also working on Stretch and Processing 3.4.
Using the latest version end up in video is working, movies didn’t show up (only white window).

I tried it yesterday on Buster using the latest processing arm release. So GLVideo < 1.3 works well.

But for today I’m struggeling to build opencv4.2.0 ;->

On Buster! I’ll try Proceesing and GLVideo later this week.

Processing 3.5.3 on a Raspberry 3+ using the latest Raspbian (Buster) is working well. Using GL Video 1.2.3 both camera and vidoe seems to be OK.
I also make building opencv 4.2.0, unfortunately still without java bindings.
But anyway, opecv videocature support udp streams. No I can send video stream from processing into python either on the local host and into my loal network.

Sorry Steve, only just saw this. Didnt have much joy, was getting really low framerates on playback (didnt test with camera), havent had time since.