Export with serial () library does not work

Good morning all,
My sketch works fine with IDE but after an export (.exe) the program crashes. (Both x32 and x64.) This only happens when I introduce the SERIAL library.
Anyone know why?
I am not the only one with this problem.
Thank you.
PS: excuse my very poor English …


Welcome to the forum! :wink:

Can you run the program from the command line and tell us if there’s an error or any kind of output in the console?

Also you can give the details about the Processing version / library you are using and your operating system.

With the command line nothing happens except the appearance in the task manager of
“Java ™ Platform SE binary”.
I have to modify a sketch written with

  • Processing 2.1.2 (I must not use Processing 3)

  • ControlP5 2.1.2

under WINDOWS 8.1 (x64)
I have tried several versions of ControlP5, Processing X32, Processing X64…
nothing happens and the program hangs.

Thank you for your help

1 Like

That seems very difficult to fix given the version you are using. At least can you share the code?

Have others got it working?

I suggest getting a working copy and trying it on your PC to see if that is the issue.

Why the constraints on this?


1 Like

I found !
I have removed JAVA RE. from my computer. When I run the sketch, it asks for JAVA RE version. (old version)
Now I will still try to upgrade to Processing 3.
Thank you.