Adding Sound Library

I need to preface this by saying that I don’t have a lot of working knowledge of the program. I am a Tech Director at a school and I was asked to add this to a handful of student laptops so they could use it for a class. I added it as requested with the understanding that teacher requesting it was responsible for making sure it worked. I hoped to wash my hands of it. However, they have run into an issue where they cannot add the Sound Library. They were able to add two of the other libraries without issue. When they click to add the Sound Library, it says download for a second and then indicates there is an error. As I said, I don’t know anything about the program, but if two work without issue then it is unlikely the network causing the problem unless this library does things dramatically different when downloading then the other two. So the questions are:

  1. I searched but I didn’t find where someone had this issue. Did I miss it? If I did, can you direct me to the solution?
  2. Failing that, what are some troubleshooting techniques I can do? Are there any whitelists specifically for adding libraries?

I appreciate any help that you can provide.

A bit more info might help.
What were the two libraries that installed?
What was the actual error message(s)?

The two libraries that installed were Beads and SuperCollider client for Processing.
The error message was “Error during download and install of Sound.”

Thank you.

Did it fail for all students?

Have you tried it again it may have been a temporary problem?

From the students:

It was the same for the other person who had got to where we were supposed to download it. Moving on, we found that the Minim library would not download either, with the same error message."

So it looks like none of them can (out of five), and there is at least one other library that won’t install.

The fact that you can download some libraries and not others is puzzling as I have personally never experienced problems using the Contributions Manager.

All the libraries available in the Contributions Manager are either provided by the Processing foundation (e.g. Sound) or third party developers (nearly all the other libraries). Each developer provides a stable URL where the Contributions Manager can download the library from so different libraries can be from different host servers. I don’t know if that will cause an issue with your network. :thinking:

Is it possible to try installing one of them away from the school network?

You might try installing one or more of my libraries because I know that all the links work, you can choose any from G4P, Shapes3D, Sprites, AI for Games, Steganos, QScript and Jasmine, they are good ones to try.

Also make sure they are using the latest version of Processing 3.5.4

If anyone else has any ideas please chip in, this is not my specialist area and I am probably missing something obvious.


This is the location of the sources.conf listing that Contribution Manager periodically uses to update its local metadata cache.

The txt files contain the metadata.the package is installed from a .zip file corresponding to the .txt URL.

So, if your students are trying to load Sound, with metadata at

Then it will drop the .txt and add .zip, and attempt to download from

1 Like

THanks! They got it working with what I think is a pretty similar process to what you have described.

1 Like