ControlP5: frame not working in Mojave

Hi all,

Got a new Mac Mini today to run an installation and it has Mojave. Installed Processing with nothing else on the machine, installed some libraries including controlP5, and tried running the included example ControlP5frame (available from the “file->examples” dropdown menu under “Contributed Libraries/ControlP5/extra” so I won’t repost the code here). Without any changes whatsoever, it hangs - first frame opens but stays grey, second frame does not open. Spinning ball. No error message.

Many other ControlP5 examples seem to work. Same code works on same version of Processing on a laptop running High Sierra. Is it the OS?

Any thoughts? Any similar issues? Can anyone reproduce?


It seems to work for me. Have you stepped through the code with the debugger / printlns and tried to find out where it stops? Without an error message or specific line of code it is not possible to find a solution.

The debugger remains busy, and this is the error message that we get. We’ve noticed this error message before on Mojave but it didn’t prevent the program from executing.

With println debugging, it looks like it enters the setup function, but doesn’t even run line 26 (cf = new ControlFrame(this, 400, 800, "Controls");).

Processing 3.5.3 on MacOS 10.14.4

about the error msg, difficult to read,
could you compare if it is same like
Trouble running P3D on MacBook here?

I have the same error messages on my MacOS (on any sketch). It don’t think it has something to do with the specific problem.

Here you can see the message (happens on any sketch).

0   AppKit                              0x00007fff4c20dccc -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 386
1   AppKit                              0x00007fff4c20b07c -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1488
2   AppKit                              0x00007fff4c20aaa6 -[NSWindow initWithContentRect:styleMask:backing:defer:] + 45
3   libnativewindow_macosx.jnilib       0x00000001320263fe Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
4   ???                                 0x000000011b778a88 0x0 + 4755786376
1 Like

Yes very similar. And I have seen that message before no matter what we run in Processing (even successfully ) using Mojave. Not sure how relevant it is to the OP regarding controlP5, but would be good to know what it is . (seems to be some kind of stack trace)