Canvas black when viewing Pi via VNC


#1

Hello,

I noticed that while I can see the processing canvas fine on a monitor via HDMI, connecting to the Pi via VNC makes the canvas appear just as a black rectangle.

Is there a trick to overcome this limitation, at least for debugging, and have the canvas rendered also on a VNC client’s display?

Thanks


#2

in the server
++ options
+++ troubleshooting
++++ enable direct capture mode

( this was called experimental … in older versions )

but first i should ask you if you use
RPI full / fake KMS ( i do NOT here )


#3

Great, I will try that. Don’t know which GL mode I’m using; I started with off the shelf Raspbian Stretch, so it would be the default I guess.


#4

see here:


#5

Yes, it’s a mix of 3B and 3B+ machines; the raspi-config shows that G1 full is selected. I can confirm that it works when I select “enable direct capture mode”.


#6

not so sure it tell you anything about how it is set?
usually it is on LEGACY,
( would take a while to find where/how that is to find,
just for info in KMS mode you loose all your display resolution settings
( and are not even able to set them again! )
and might not see full window in HDMI

the KMS mode i only use if there is a Processing example ( some P3D)
what just not run in LEGACY mode

and again, i just say i did not test VNC in that mode… thats it.

? is it like a school class setup where you want check in from one computer
onto many RPI? ( use fix IP-setup ??)