Can't use libraries


#1

Hello,
I really want to use libraries on Android. Although if I import them, I get a few errors in the console:

name.jar is mentioned in export.txt,
but it'sa big fat lie and does not exist.

I followed the manual install guide.
How do I install it properly and use it correctly?

Btw, what’s better: Beads or Minim?


#2

Unfortunately Beads or Minim don’t work on android mode


#3

Then are there any Sound libraries, that work on Android? Preferably with FTT and sound player.


#4

The new sound library works in Android mode! The only problem I ran into was audio input.


#5

@calsign Well, that’s great news! I only ever used the stock libraries. Although I need the library files and I can’t use github :smiley:

Still can’t install anything by “Install compressed library”. Can you guys do something about that?


#6

Oh, you’re using APDE. It might be a good idea to mention that because APDE is a little different from desktop Android mode.

A quick note: the new sound library is the stock sound library. Minim and Beads are contributed libraries. I sent the link to the GitHub page, but it is also listed on the libraries page.

First, the current version of APDE does not support the sound library, but I have released a new version to the preview channel that supports the sound library. So if you want to use the sound library now, you should join the preview channel and follow the instructions at the top to receive preview builds. (The correct version of APDE is 0.5.1-pre4, or anything later than that.)

What do you mean when you say that you can’t use GitHub? You can download the sound library from the releases page on GitHub (sound.zip). If the “install compressed library” tool doesn’t work, then the manual installation should still work. However, it is possible that the library installer was failing in the past because you were not using a properly formatted library. I have used the zip file that I linked above and it is definitely properly formatted, so you might want to try that first.

If the installer still doesn’t work, then please provide more information about how it fails specifically. Also check previously-created issues on the APDE issue tracker and create a new one if the problem that you are experiencing is not one that has already been described.


#7

I already reported the “Install compressed library” issue 3 months ago.

About GitHub, I don’t use GitHub for anything other than downloading files, so I don’t know, how to use commands like git clone. The folder library does not contain any .jar files.

The installer failed on everything I’ve tried. Sound, Net, Minim, Beads, Cassette (and Cassette is made for android mode). It goes something like this: I tap “Install Compressed library” and Google Files shows up. I select the .zip file and immediatelly APDE crashes. Though I had a trouble with Google Files before. When you select a file, it sends an adress without the file type part.
Ok, now I’ve tried it with ES File Explorer and it worked. So, the Google Files app caused issues. Someone should take down that issue. I’m sorry for that. :frowning:

Now, the folder library is empty…


#8

Ok, now I have it. I have no idea how it happened, but I opened the link you sent me a few times and only once the download page opened. Before it was the repository page.