After multiple installs processing wont start, independent of version

Context
Im in college and for a class my teacher is using processing, everything was going fine until we needed to use the contributions manager to download a library for some assingments. At first I couldn’t use any of the resources of the libraries and none of the examples were working, so I tried to unninstall processing.
We were using 3.5.4, I started using the 4 beta and the problem persisted, after talking to my teacher and some research I attempted some of the fixes, none of them worked. Later my teacher sugested that I should reinstall processing, I shared my screen and installed and reinstalled processing many many times, this leads us to my problem now.

Description
Processing wont start, inpedendent of method. The window of processing shows up for about 1 second then it closes. Dont know if this is usefull but in every attempt of reinstallation I deleted the processing folder in Documents, in Roaming/ AppData, and the extracted file after the download. Now every time I try the .exe nothing happens.

Expected Behavior
Whenever we open processing.exe, after displaying the logo window, the editor should open up.

Current Behavior
It doesnt respond, depending of version a window opens and closes after one or half a second

My Environment

Processing versions: 3.5.4 / 4.0 beta 1 / and also attemped 2.2.1 with the same results
Operating System and OS version: Windows 10 Pro
Other information: 64bit