When i build this application it just makes a blank grey window

okay i’m sure this is a very common problem but i haven’t found anything helpful, i’m just getting a totally blank grey sketch window when building a processing app for mac. this is the first time i’ve had this error, every other app builds fine. is this a know issue and what are some causes?

i’m not sure how to provide helpful info here, there’s no error messages or anything. idk if i should just post the entire app code because i doubt that’s the cause, but here’s just the main class in case i’m setting up the surface wrong

float SEED = 0;

void setup(){  
  size(500,500);
  surface.setResizable(true);
  frameRate(30);
  colorMode(HSB);
  initGraphics();
  initWorld();
}
void draw(){
  uiUpdate();
  runWorld();
  runCam();
  RENDER();
  if(iENTER==1){
    compile();
  }
}

let me know what kind of information i can provide to be more helpful, i know that’s not a lot to go on

**
update: just tried it on windows and i’m getting the same thing, just a grey screen. no errors, and the window is the size that i initialized it to be, resizable like i set it to. just no graphics, it’s all grey

1 Like

Your code does not look like js.

Can you provide more details?

Reference:
https://p5js.org/get-started/

:)

This is processing code not p5js but without knowing what your funtions do its anyones guess whats going wrong. If your installation is as it should be then i can’t diagnose with just this.

thanks, i’m just not sure what kind of things cause the sketch to grey out like this so i really don’t even know what to look for. again, there’s no error messages or anything so i don’t even know how to look for a problem here

When this is the cases i would usually uncomment all functions and then one by one allow them back into setup or draw. This will at least help you to pinpoint which method or methods are causing the issue.

I am new to processing. I used Python mode. Noticed same issue (gray window), when setup declare size() with P2D or P3D.

While testing, even removing those. if I use a 3D function (I tried line() only), window goes blank again.

So, in an example I have tested, changed these to fix it:

  • size(x,y,mode) => size(x,y)
  • line(x1,y1,z1,x2,y2,z2) => line(x1,y1,x2,y2)

Weird that process, doesn’t show any message. But I expect the issue is with OpenGL libs.