Video library not compatible with version 4.0b7

I try to import the Video GStreamer based library Version 2.0 in Processing 4.0.b7. The library manager complains “2.0 not compatible” I tried to download and install it from Github, but the IDE does not see it. According to the changes document it should be working so I wonder what goes wrong.

Hans Lasschuit


I was able to add the Video Library for Processing 4 Version 2.1
to Processing 4.0b7.



After stopping and starting Processing I see this:

It does appear to work once installed and I ignored the that it still shows it (installed and not installed) in the Libraries tab. This may be a bug.

I keep separate folders for Processing 3 and Processing 4 in Windows Documents folder. You can change this in the Preferences in the Processing IDE.

The examples that come with the Processing IDE worked… the few that I checked.


1 Like

Great! It appears now in my library management tool too!. And after some startup issues i now manage to capture the devices

1 Like