Error in Video librarie

I try the example “GettingStartedCapture” and the following line throws error

String[] cameras = Capture.list();

UnsatisfiedLinkError: Error looking up function ‘gst_date_get_type’: /usr/lib/x86_64-linux-gnu/libgstreamer-1.0.so: undefined symbol: gst_date_get_type
A library relies on native code that’s not available.
Or only works properly when the sketch is run as a 32-bit application.

I have Processing 3.4 64 bits on Ubuntu 18.04.
Thanks for your help.

1 Like

Can you post what you get when you type in the terminal uname -a?

Kf

kfrajer, when I execute uname -a I get:
Linux lisandro-Notebook 4.15.0-30-generic #32-Ubuntu SMP Thu Jul 26 17:42:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Ok, can you please check this https://github.com/processing/processing-video/issues/71 as they discuss the issue there.

Kf

I’m downloading a new zip with library inside. I test what happens after installing it and I tell you.
Thanks!

I download the zip file and install it


and finally works!!!

Thanks!!!

1 Like

Great, good to hear it is working!

Kf

The beta version based on Gohai’s fork is at https://github.com/processing/processing-video/releases/tag/r3-v2.0-beta1

2 Likes

Hello Lisandro

! I see this error. Could you help me? I have Ubuntu Ubuntu 18.04.1 LTS

I do not know how you made it work.

Thanks!

Use the link I shared above and check the info for installing libraries manually.

1 Like

Thank you. I just downloaded and changed the library to the correct folder.

Windows showed me the sizes of video that the camera was using, in Ubuntu they do not appear.

That’s something @gohai might have a handle on? Some of how this worked changed in GStreamer 1.x and I’m not sure how fully featured the new version of the Video library is here.

Hello, could you please explain the steps you have done because i am facing the same problem? Thank you in advance.

As pointed above:

  1. download the [Video Library Release 3 (version 2.0-beta1)] here:
    https://github.com/processing/processing-video/releases/tag/r3-v2.0-beta1

  2. Extract the downloaded zip file into your Processing library folder.
    This is a folder named “libraries” inside your sketchbook folder.

    "To find (and change) the Processing sketchbook location on your computer, open 
     the Preferences window from the Processing application (PDE) and look for the "Sketchbook 
     location"  item at the top"
    

    Full instructions about this here (Manual Install):
    https://github.com/processing/processing/wiki/How-to-Install-a-Contributed-Library

  3. Start Processing and try one of the examples for the video library
    MENU: File -> Examples… Contributed libraries -> Video

Thank you very much for your fast response, i follow the steps but the library is still not recognized. I am working with Ubuntu 18.04.

-a- i try on WIN 7 64b
( even there is a open ISSUE
Issues · processing/processing-video · GitHub ,
that it might not work )
but no problem / to run a show video example.

-b- steps:
-b1- download


-b2- unzip to libraries

-b3- open/restart Processing / check examples

what does your info mean?

if you not find the examples you use the wrong path.
if you find a example and try to RUN, what was the error msg.

Thank you very much. I am sorry that I did not answered fast. The libraries are working now and i am searching this error. “A library relies on native code that’s not available.
Or only works properly when the sketch is run as a 32-bit application.”

1 Like