Video library GStreamer Ubuntu

Hi I’m out of ideas,
I’m having an issue with the video library in processing 4.1.1.
On a new computer running ubuntu studio 22.04.
The weird thing is, I had the exact same issue on my old laptop running ubuntu studio 20.04.
I have the video library installed and imported, it shows no errors, however when I run it, it just opens a blank grey subwindow. The console shows it fails to find
all related to gstreamer
i reinstalled them (they were installed) through synaptic that didn’t change anything.
i deleted these files in the processing folder and replaced them with links to the files in /usr/lib/x86_64-linux-gnu. That helped, other library issues showed up, so I replaced the entire gstreamer-1.0 folder in the processing folder with a link to the gstreamer in /usr/lib/x86_64-linux-gnu. That solved (or just disabled) everything except one.
Now I am stuck on this issue
Processing video library using bundled GStreamer 1.20.3 (CVS)
Scanning GStreamer plugins…no more csLADSPA plugins
RuntimeException: Could not load movie file

I tried do put a link to the csladspa shared lib in the gstreamer linked folder but I had no rights to do so even after using chmod.

Why are there two different versions of the gstreamer libraries? One in the processing folder and one under /usr/lib/x86_64-linux-gnu.
What does this csound ladspa library have to do with anything?
And please can anybody help? Am I the only one who has this problem on two different machines? I couldn’t find anything anywhere.

Greetings and Happy Holidays everyone