Use Kinect 1 or 2 sensors with Processing 2 or 3

I got it working quite well on Ubuntu. You might need to install libfreenect.

Actually I did, but it didn’t work though. Which version of Ubuntu are you using?

[UPDATE] actually I have libfreenect installed, I use openFrameworrk kinect examples which is based in this library and it works correctly.
This is the error I get when I run the User example of SimpleOpenNI

> Can't load SimpleOpenNI library ( : java.lang.UnsatisfiedLinkError: /home/rossig/sketchbook/libraries/SimpleOpenNI/library/ it can't open the file of the shared object. The file or directory doesn' t exist.
> Verify if you installed SimpleOpenNI correctly.

I created a soft link to thiis one by doing
sudo ln -s /usr/lib/x86_64-linux-gnu/

It didn’ t work either.

I made this project some time ago and forgot, but apparently I was struggling with the same problem. In my ~/sketchbook/libraries the SimpleOpenNI is a symbolic link pointing to git SimpleOpenNI repository clone. Apparently I was assuming that I can build it. But I believe that all the binaries are actually distributed in this repo.

$ git status
On branch master
Your branch is up to date with 'origin/master'.

Untracked files:
  (use "git add <file>..." to include in what will be committed)


nothing added to commit but untracked files present (use "git add" to track)

So some files differ, but I cannot tell how I obtained them. I can send you the copy of my repo. And then maybe you can post an update what was actually needed to fix it?

Here it is:

Thanks @morisil, sorry for my late response, I’ve been working on other project. I will put my hands on it, we’ll se what happens.

It seems the link time has expired.


Finally I got it working on Ubuntu 19.04. My mistake was the place where I created the softlink, I created it under the plugin library folder besides the one I created under /usr/lib/x86_64-linux-gnu/.
So the steps were the following:

  1. reinstalled the pluging to get the correct library and to get a fresh plugin folder.
  2. I left the one I created under /usr/lib/x86_64-linux-gnu/ (sudo ln -s /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ )
    @morisil post gave me the hint.

@rossig7 I’m glad that it finally worked.

I used Kinect 2 with processing 3.5.3 and download library(SimpleOpenNI-processing 3.5.3) but it’s fail
this is photo of error. How can I solve it?