Use GPU instead of iGPU for shaders

How could I force the program to use the GPU instead of the iGPU?


Been developing a program on my desktop, where it runs fine. The issues show when I try to run it on my old laptop.

Program uses shaders, relying heavily on the GPU, and when it gets a bit more demanding it crashes.

Using the task manager I noticed the crashes happen right after a spike in GPU usage. Also noticed that the program is using the weaker iGPU [Intel(R) HD Graphics 360] instead of the GPU [NVIDIA GeForce GTX 1060 with Max-Q Design].

Edit: Running Windows 10 and already tried updating drivers.

The error thrown is:

# A fatal error has been detected by the Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ff9e85e4d3f, pid=7524, tid=22512
# JRE version: OpenJDK Runtime Environment Temurin-17.0.6+10 (17.0.6+10) (build 17.0.6+10)
# Java VM: OpenJDK 64-Bit Server VM Temurin-17.0.6+10 (17.0.6+10, mixed mode, sharing, tiered, compressed oops, compressed class ptrs, g1 gc, windows-amd64)
# Problematic frame:
# C  [ig9icd64.dll+0x5d4d3f]
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
# An error report file with more information is saved as:
# E:\programs\Processing\processing-4.2-windows-x64\processing-4.2\hs_err_pid7524.log
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
Could not run the sketch (Target VM failed to initialize).
For more information, read Help ? Troubleshooting.



Managed to fix the issue!

Solution is changing program’s default GPU.
Chosen program was java.exe at processing\processing-4.2-windows-x64\processing-4.2\java\bin\java.exe