Unable to use P3D

Everything worked just fine yesterday, but now I cannot even run a simple sketch like this:

void setup() {

void draw() {

When I click “Run”, nothing happens.

Please let me know if I can provide more information.

How long did you wait? Processing can take it’s time to start up, especially with P3D.

Please provide OS, Processing version. I can only suggest to reinstall Processing. Before you do that, attemp any of the examples using P3D.

For documentation, please provide graphics card model, if known.


I’m using Surface Pro with Windows 10 Home 17134.167, Intel Core i7-7660U, Intel Iris Plus 640, Processing 3.3.7 .

Another thing is that I can run sketches after export but connot run in Processing IDE.

Did this ever get solved? I have the same trouble with 3.4

None of my 3D code works! Processing simply stops, does not respond forever.

I am facing the same issue.Using windows 10 & intel i5-7600K , Intel HD graphics 630.
It shows no error but the window is never displayed with P2D & P3D.

better open a new thread as digging up a one year old…

thanks for the hardware and OS info,
you use current processing 3.5.3?

the GL driver seems to have a problem,
hopefully a driver update helps?