Problem with P3D on Mac OS 11.2.1

If I run this:

void setup() {
  size(100, 100, P3D);
}

I get an error:


	0   AppKit                              0x00007fff22e8147f -[NSWindow(NSWindow_Theme) _postWindowNeedsToResetDragMarginsUnlessPostingDisabled] + 352
	1   AppKit                              0x00007fff22e6c121 -[NSWindow _initContent:styleMask:backing:defer:contentView:] + 1375
	2   AppKit                              0x00007fff22e6bbbb -[NSWindow initWithContentRect:styleMask:backing:defer:] + 42
	3   libnativewindow_macosx.jnilib       0x0000000133b3d3fe Java_jogamp_nativewindow_macosx_OSXUtil_CreateNSWindow0 + 398
	4   ???                                 0x0000000119632a88 0x0 + 4720896648
)

I think this question has been answered before but I cannot find an answer. I assume I have to do something clever with Java but I do not want to start replacing *.jars without fully understanding what I am doing.

Did you try FX3D instead ?

Hi, No I did not try to launch P3D from inside a Java application. Is that what you mean? There would be no point as the rest of the sketch is in Processing. I have only shared the one line of code that is giving the problem.

No I meant tried something like size(100, 100, FX3D);

Ah, now I have tried:

void setup() {
  size(100, 100, FX3D);
}

“The variable “FX3D” does not exist”. Do I need to import a Library to use FX3D?

Ah my bad, there doesn’t seem to be any FX3D implementation in Processing yet. However you could try adding frameRate(); while using size(100, 100, P3D);. I remember this solving my issues with it (Also, it is mentioned here). Tell me how it goes

Thanks! Yes, this works:

void setup() {
  frameRate(60);
  size(100, 100, P3D);
}

I still get the same error report but the sketch works. We can limp along like that until Processing 4.

2 Likes

chick if your vga card support 3d or not

Yup
AMD Radeon Pro 5300M 4 GB
https://www.amd.com/en/graphics/radeon-apple-5000m-series

chick the driver then