Size() not working Processing 3.5.4

Hi there, I’ve been reading several topics here about a similar issue but I couldn’t figure out what my problem is.

Size() is not working in my Processing 3.5.4 sketch. This gives me a sketch that takes up the space of the whole screen (not in fullscreen mode, just windowed):

void setup(){

Any idea of what the problem might be? I also tried downloading 3.5.1 and 3.5.2, as I read somewhere that an issue with size() had been fixed in those versions, but it doesn’t work either.

Thanks for your help!

1 Like

What is your OS?
I cannot reproduce this issue in Windows x64. I am using P3.5.4

Does the issue persist if you add an empty draw() function? If you run using the P2D renderer?


Under menu choosing preferences, there is a box with the text, “Execute sketches on the screen …”. What do you read there? Is it settable or grayed?
Also open the link in the same preferences window, and open ‘preferences.txt’. At the bottom you will find “run.display= 1” If it’s not there, write it. If it is set to “0” ,the sketches have a full window size like you mentioned.
To make changes in the preferences file you must edit it and save it with the processing’s ide closed. After saving reopen.


Changing “run.display” value to 1 solved it!

Thank you very much :slight_smile: