Simple OpenNI Error opening database/parameters


I’ve just come back to a project I was working on a month or two ago, and while it was working fine back then (and I haven’t messed with the folders it exists in), any sketch that involves Simple OpenNI comes up with the following error:

SimpleOpenNI Version 1.96
Error opening database/parameters file.
After initialization:

Could not run the sketch (Target VM failed to initialize).
For more information, read revisions.txt and Help → Troubleshooting.

I’m using macOS Mojave 10.14.5 and processing version 3.5.3, neither of which have been updated since I last ran the sketch.

This error must be for Simple OpenNI, as the same error message comes up for every sketch in the examples folder of SimpleOpenNI (installed from Also I couldn’t find a revisions.txt to read!

I suggest you open an issue there if you haven’t done so.


Thanks, I’ve done this!

I figured it out!

It was just a little thing mac does if you have icloud setup - and not a huge amount of storage left on your device. It’s been auto-uploading entire folders to the cloud and completely removing them from the hard drive (without telling me of course) to free up space, so when I ran SimpleOpenNI after a month or so, the libraries were no longer physically on my computer.

Silly error. Lots of frustration. But now I know.