RockPro64 doesn't execute Processing


#1

Hi everybody,

I wrote a processing sketch for a photographic installation. I wrote and tested it on my Macbook, and it works like a charm.

Now to include it in the installation I bought a ROCKPro64 4GB single board computer. But I can’t get Processing to work on it.

As an OS I installed “Armbian Ubuntu 18.04 Bionic Desktop” and “Ubuntu 18.04 Bionic LXDE Desktop aarch64”. (see http://wiki.pine64.org/index.php/ROCKPro64_Software_Release).
I tried both the Linux 64-bit and Linux ARM release of Processing in both OS’s. But on execution nothing seems to happen.

Does anyone have a clue on why it’s not working? Or even a hint to solve my problem?

Thanks in advance!


#2

-a- what / how you install processing,
-b- did you test

java -version

like on Raspberry Pi


have 3 way,

  • a image
  • a curl command ( i used )
  • a tar file

and on

pi@RPI3BP:~ $ java -version

java version “1.8.0_65”
Java™ SE Runtime Environment (build 1.8.0_65-b17)
Java HotSpot™ Client VM (build 25.65-b01, mixed mode)

i understand you think you might be lucky if someone here use the same board,
but did you try to ask other board users like at
https://forum.pine64.org ?


#3

Sorry for my late response, but had to figure out some stuff before I could answer the questions. I’m new to Linux and struggling getting things to work. ANd thanks kll for your response.

  1. I tried the Raspberry image, but it didn’t even boot

  2. I now use “Ubuntu 18.04 Bionic LXDE Desktop" as the OS. I installed “Processing 3 Linux ARM” bij downloading the package and unpacking it to /opt (using sudo xarchiver). I opened LXTerminal and tried to run Processing by making /opt/processing-3.5.3 the current folder (cd /opt/processing-3.5.3) and typing ./processing. Response: java: not found.

Than installed Java by first typing
sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt install oracle-java8-set-default

Than again tried to run Processing by making /opt/processing-3.5.3 the current folder (cd /opt/processing-3.5.3) and typing ./processing. This results in a java.awt.headless exception

And that’s where I am now…

I have only slight understanding of what I’m doing. But turns out that ‘headless’ means without monitor, keyboard or mouse. But I have no idea of how to get java into headful mode.

Am I on the right track?

Anybody any suggestions?