Can't open Processing after downloading

When I try to open Processing after downloading, I get the message below:

I’ve tried following the instructions in the screenshot, restarting my computer, and redownloading, but keep getting the same response.
Using a MacBook Air with Ventura 13.3.1. Any ideas?

1 Like

Did you unpack the zip file

Did processing prompt for access?

Yes I unpacked the zip file. Double clicked on Processing, it started to open, then message appears as above. There was no prompt for access. Tried multiple times.

1 Like

Sorry, I can’t help you, I don’t have a mac

That’s OK, thanks anyway :slightly_smiling_face:

I searched it here in the forum


SmantikVJ commented Nov 10, 2022

I think I have found the solution.
I have gone to Security & privacy, I have entered user administrator username / Password to unlock the editing screen and inside Privacy tab I have selected “Documents & folders” and let Processing to access (tick was deactivated before). I did the same selecting “Total access to disk”.
Now, the window “We’re on the wrong foot” does not appear (I didn’t have to reinstall Processing).

(from Processing Crashes upon start (macOS Ventura) - #4 by josephh)

You should get the prompt, but you didn’t, so maybe Apple changed this in the OS.

Anyways, above seems to allow to give permission for the folder for processing (when acting as Admin)


That worked - thank you so much!

1 Like

:smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile: :smile:

1 Like