Processing doesnt work now

I’m using a chromebook that runs linux in a container. I downloaded processsing 3.5.3 a month ago and things worked great. I got a message today when I went to start the chromebook that an important update was being installed dont turn off. Now when I try to run processing, it says:

"java.lang.InternalError: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped "

I did the “sudo apt-get update” and sudo apt-get upgrade and some stuff downloaded but the error is still there when I try to run my sketches. When processing starts, some of the buttons in the ide are blanked out black.

1 Like

try with this:

1 Like

Yes sir, that’s the bug. I’m not sure how to apply the fix. There is a link to source code that fixes it in the jogl-all.jar file. So do I unpack the jar, stick in the fixed code, recompile and pack it into a jar and copy it back into the directory? I guess I need to learn to compile processing from source.

I tried the 5 minute fix from the link. It almost worked. I replaced the GLContextImpl.class and repacked the jar, then copied that to the core/library directory for processing and got a different error.

Now it says:

java.lang.RuntimeException: Profile GL3bc is not available on X11GraphicsDevice

I just spent $7.00 on a USB drive to see if I could take an “exported to linux” sketch and run it on the chromebook. No dice! The stacktrace is riddled with messages about jogamp and jogl and illegal access and no X11, etc. Chromebook didnt like something about Processing and decided to break it real good.

I’m still trying. I got the bright idea to try the alpha version 4.0a1 of processing since it is based on jdk11. I still get an error that is slightly different but along the same lines.

java.lang.InternalError: XXX0 profile[2]: GL2 -> profileImpl GL3bc !!! not mapped

Any ideas how to “Map” GL ?

I’m limited to crude solutions. I have to wipe it all clean and start over. I blame it on the Chromebook update, but I also installed WolframPlayer. Then I installed some mesa package to try to run a diagnostic to give me output that I wouldnt have known how to interpret anyway. Goodbye Cruel World! :grin:

Nuke option worked! I tried a P3D example in 3.5.3 and all is well. I think my problems started right before the chromebook update when I installed WolframPlayer. I could test that at this early stage of the new install without wasting a bunch of time.

1 Like

It worked for about a year, but it’s back. I can’t run anything that uses P3D/OpenGL and get basically the same message, except it is java.lang.InternalError: XXX0 profile[1]: GL3bc → profileImpl GL4bc !!! not mapped.

Oh well, nuke option again.

Before I go caveman on it and delete it all, I tried processing 2.2.1 and OpenGL/P3D sketches work as long as it doesn’t use some library version that only works in 3.5.3.