Problems running P2D and P3D in 7y old laptop

I’d like to run Processing in an old computer (Acer ES1) with Xubuntu , but while everything seems to work fine, when I run sketches that use P2D or P3D I get the following error:

InternalError: XXX0 profile[2]: GL2 -> profileImpl GL3bc !!! not mapped

This happens with Processing 4.1.1. (as well as 4.0 and 3.5.4). In my understandings the issues is about an old bug that has been solved in the recent version for most of the machines, but not for mine. I suppose the bug should be related to this:
P3D don’t work on AMD dynamic switchable graphics #5308

I tried to follow all the possible workarounds suggested but nothing worked out. The only thing I didn’t try and that I would avoid is downgrading the version, since I need to work with the latests.

I would be very thankful if someone can help.

Hi @div-p,

Just providing the link to this post:

Thanks @josephh … I hope I didn’t cross-post… I guess it’s the same problem but on different specifications

1 Like

The solution is supposed to be here:
InternalError: XXX0 profile[2]: GL2 → profileImpl GL3bc !!! not mapped

However I didnt have chance to try it out, its maybe something for Processing developers?