Problems Exporting a Sketch on Mac

Hi there!

I have written a program which utilises multiple libraries to control a particle system using a kinect. All data is stored within the data folder. It runs fine within the processing environment. My problem is that when I export the application as an app for MAC or a .exe file for windows (I have tried running the exported files on both OSs) the program does not run and only displays a white screen. I have tried exporting with/ without embedded java and in/ out of presentation mode and these factors make no difference.

I have a feeling that it is something to do with processing export of the libraries as when I export a simple application with no libraries I do not encounter this problem.

I am running MAC OS sierra 0.12.6 and my Processing version is 3.3.7.

Below are the libraries I am using

import org.openkinect.freenect.;
import org.openkinect.processing.
import org.openkinect.tests.;
import shiffman.box2d.
import org.jbox2d.common.;
import org.jbox2d.dynamics.joints.
import org.jbox2d.collision.shapes.;
import org.jbox2d.collision.shapes.Shape;
import org.jbox2d.common.
import org.jbox2d.dynamics.;
import org.jbox2d.dynamics.contacts.

1 Like

Can you copy your source code to your mac an run it from there? This will allow you to see if the libraries are compatible, for starters. If the sketch works from the PDE, then you can export it and the generated export folder should be compatible with any Mac.


Hey, I’ve actually run it on my MAC and on a PC, both work fine in the processing environment, but both the exported versions both have the same problem unfortunately.

Sorry, I misread your post. Having library and external resources makes it a bit more complex. What external resources are you using as in images,sound, ascii files, own config files, etc.? The first thing is to make sure that the data folder is placed properly in the exported folder. When you export the folder, go into the export folder and make sure your resources were also moved. An easier way is to create a mcve only targeting this operation.

If this is not the problem, then it could be your libraries. I can only guess but what you could do is to build a small program with the library in question and exported and make sure it works. As an alternative, instead of writing your own mcve, you could run an example provided by the library and export it and see if it behaves properly.

Also, stick to one OS for now.


No sweat! I am only using image files. However, I am using many image files to create animations within the program. Could this present a problem with memory?

That’s a good idea, I will try exporting the library examples to see if they work.

What exactly is mcve? I’m not familiar with this term.

Thanks man!

MCVE explained.

If your program works in the PDE, it should work as an exported application. In short, there shouldn’t be any difference running your code in either scenario.



So I exported a few examples from the libraries I am using. The Open Kinect library examples had similar issues regarding the export, (The application did not run and presents only a blank screen). Is it reasonable to assume a problem arises with this library during the exporting process?

EDIT: I have actually manage to export a program using this library so it is in fact not the problem. I will create a MCEV and post here when I get a chance.

Can I get a bump on this?

I’m having the same problem: OSX High Sierra, P5v3, Open Kinect for Processing Kinect_v1.

I’ve tried exporting with 13 known working sketches, including the supplied examples. All fail with the above described behavior… blank window opens. (No crash, quits fine, but no action.)


1 Like

Has anyone found a solution to this problem?

I’m having the same issue (on MacOS 10.12.6, Processing 3.4) . Perfectly working sketch (simple, no libraries) inside Processing environment but won’t run when exported (animation window opens blank with no crash or error messages).

Thanks for your help!!

Solved my problem! So in case it helps others:
The problem was the data files the sketch uses (a couple of .csv in my case) are NOT exported into the standalone applications folders. I manually moved them into the application folder and it ran without a bump.