Problem with* library in Android

<!-- Tips: Hello I have a Processing sketch running OK on JAVA. The sketch uses the* library. When compiled for Android, I get an error message: "No library found for". Can anyone have an idea to solve this problem. Thanks Mike

You have to import your library into the sketch. Search the forum for keta lib problems solution is in the thread.

1 Like

I tried to add the ketai library through the sketch/add library menu.
I get an error message “Error during download and install of Ketai.”

What about installing any lib through the menu.

Also i didnt mean add ketai i meant add it throught the menu. If that fails, create a folder in your sketch folder called codes and place it in there. Provided you have the jar file, which you might be able to find on google otherwise.

this one works on android just unzip it to sketchbook

with my link works direct on android its from @noel :heart:

I generally go direct to a reliable source for code.

You posted a link from someone or somewhere to a Google Drive from someone else without any details and spelled his name wrong.

The ketai website is now down.

The download link for the latest v14 is not working since the site can’t be reached.

The details and context are important if you are sharing code; version, source, author etc.

Fortunately, I do have a download of v14 from the original ketai source in my personal archives and also the library (also v14) installed from the Processing PDE.

There is a ticket for this here.

I can’t download the ketai library (v14 is the latest) from the Processing PDE the last time I checked.


1 Like

@jafal === @glv ===
anyway you can use java for that

1 Like

Thank you for trying to help. I finally could include the “KETAI” library.
Now how can I use it to replace the “” library which worked for me with JAVA and not recognized with ANDROID?
What I want to do is open a webpage using its HTTP address and read the first line in this page.


OK, a couple of days later, I saw the answer to this post:
" Android mode import fails build".
I used the proposed solution to that post. It solved my problem. I think this solution, which provides an alternative to importing the “” library (not recognized by ANDROID) deserves to be officially published and incorporated within Processing .

1 Like