Problem with Control P5 font

Hi there! Im new to processing and I have been trying to run a model however I seem to have run into this problem


Is there any solution to this problem? When I first tried to run the model it gave the following errors:

(1) The first problem that came up was regarding missing libraries ‘ObjSaito’ and ‘Control P5’. (Fixed)

(2) The second problem that came up is regarding the font. Unfortunately, I don’t have solutions to fix this problem.

Any help is appreciated.

Judging by this older thread, you can’t use PFont, but ControlP5’s own font object, the ControlFont

Edit: In the future, please copy and paste, and format </> your code directly in the post - that way, someone can easily test it on their own machine.

Thank you for the input. I have already seen that thread, however after performing the edits it didn’t help out (not sure if that thread had the issue resolved to be honest).

Im waiting to see anyone else have faced such problems in past and how if so how was it solved.

Any help is appreciated.

Please provide a short code demonstration your issue. Also, it is very common to explore the provided examples that comes with the library. I find the library examples to provide complementary information to the online sparse/limited documentation.


Hi frajer, how do I provide the demonstration? I have no idea about coding, I am just running this model to see if it can be usable for the project I am working on. This model was developed by a student 5 years ago and I think Im facing compatibility issues right now.

This information you provided is important. If you are trying to run a legacy code, then one need to ask if this was done in Processing version 2 or version 3. If you are not familiar with Processing or programming, then it is very hard to help. For us to be able to help, you need to provide details of your project and [some] code. Notice that if there is no code, then we are shooting in the dark. If you are not a programmer, then you can ask somebody that knows some coding to help you. If you do programming, then you could become familiar with the software and with how Processing works. Try the example code that comes with Processing (They can be accessed under files>>examples after you fire the Processing Development Environment (PDE)) or checking the examples here. You should also have the reference handy to understand what each function does. You should also explore Shiffman’s videos as he explains how to get started in Processing. After you become familiar with the PDE and run some examples, then you can try running your project and posting some code.

To provide an example of the code, you can copy and paste it here, if you are sharing few lines of your code. Check the sticky post in the forum that provides direction on how to format your code when you post it here in the forum. Any other question, just ask.

For the time being, you could bypass that error by commenting out that line showing the error (add two forward slashes // at the beginning of that line). You do not need to set the font (most of the times) to get your code running. See if your code run normally after this or if you get any other error.



@239ahmf Agreed that a link or pasted copy of the code would help resolve this quickly. I tried looking for “InteractiveVM8.pde” or “RC8.obj” on Google, but no luck.

When you provide the code and assets directly then people can run it on their own machines to inspect the problem and try solutions.

Thank you so much for the advice, the bypass worked.

Additionally may I ask how do I physically find the right serial port in my computer to connect with the processing software?

My first attempt, from my Windows esperience, is to use Processing itself. You can print the information from Serial.list() before and after you connect your device. The difference in the lists indicates the COM port your device got assigned to. Using Processing to do this test is helpful as it indicates that Processing is able to see the device when is connected. If you do not see the device, then it is very likely the current serial driver for your device is “sort of” not compatible. Not sure if it is at the OS level, driver level, Java level. I have very limited experience. You can try upgrading or re-installing the driver. This calls for another level of effort to get it working by either reading documentation, contacting the company or doing some heavy google search and reaching out forums related to your product. You can even try searching old post in this forum as you might never know if somebody has tried your type of device before. I hope this answers the question.


1 Like