Problem in uploading Android sketch

Using Raspberry PI3.
I took one of the simple examples from Processing library, switched to Android mode and tried to upload it to my smartphone. I get a message “No devices found”. My smartphone is shown with “dmesg” function.
Same sketch, in Android mode, using laptop PC with Windows 10, is correctly uploaded to smartphone and running .
Any idea to solve this problem is very much appreciated.

I suffered a lot with this. Try APDE ( Play store)

Thanks for this answer.
Is it possible to upload a sketch from PC to APDE?

I tried doing that, with no luck sadly. It’s really hard to get APDE to look for .pde files. What I did was I copied the raw code and sent that to my device (I used Samsung Flow, but you can also email it). Then I copied the code which was sent to my device and pasted it into APDE

@TechMaster04 @MPROCD
I use along with APDE an app called FolderSync.
I store my sketch book on Google Drive, and the app will automatically syncronize my device and PC.