Problem in adding Android mode in Processing-3.4


#1

Hi,
I want to install Android mode in processing 3.4. I am working behind the proxies so even I have made proxy setting in preferences.txt but still it cannot do it online.
For offline mode I have unzipped the Android mode in C:\Users\Admin\Documents\Processing\modes.
But still only java mode is available in processing. Please help, I have gone through many online help but still its not possible.
Kindly help.

Regards
Simmi


#2

That’s actually not the right folder, as far as I know. There’s a modes folder inside of my Sketchbook folder, where all modes that I install actually get put into - try putting it there!


#3

Actually in windows PC at home when I have downloaded online the folder goes into C:\Users\Admin\Documents\Processing\modes. so for offline mode in my office I have used the same path.
In my windows, when I create new sketch no such modes folder is created. Manually I have created modes folder and copied Android mode folder there. Thereafter I have opened the sketch from processing but still it does not work.
I have extracted processing in E drive, I have tried saving android mode in modes folder but still it does not work.

Please suggest.


#4

i understand that you talk about a manual download ( of what from where ?)
for my understanding you run the
processing IDE 3.4 on windows

and you do
/File/Preferences/
and in that window you have adjusted / see / the path to the sketchbook location directory you use

and you do
/Tools/Add Tool/
/Contribution Manager / Modes/
find Android Mode 4.0.3
to select and install.


and you can check later that it was installed under
< Sketchbook Location >/modes/

even you can not follow this ( because of your download problems?? )
you should understand more about the path structures.


#5

Thanks , the problem got solved.