P3D mode not working on Chromebook


A first-time Processing user here.

I’ve just installed it on my Acer Chromebook Spin

I get the below error message when I try to use P3D:

size(400, 400, P3D);

Is there any way around this?


java.lang.InternalError: XXX0 profile[2]: GL2 -> profileImpl GL3bc !!! not mapped 
	at com.jogamp.opengl.GLProfile.computeProfileMap(GLProfile.java:2098)
	at com.jogamp.opengl.GLProfile.initProfilesForDeviceCritical(GLProfile.java:1976)
	at com.jogamp.opengl.GLProfile.initProfilesForDevice(GLProfile.java:1895)
	at com.jogamp.opengl.GLProfile.initProfilesForDefaultDevices(GLProfile.java:1861)
	at com.jogamp.opengl.GLProfile.access$000(GLProfile.java:80)
	at com.jogamp.opengl.GLProfile$1.run(GLProfile.java:239)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:318)
	at com.jogamp.opengl.GLProfile.initSingleton(GLProfile.java:225)
	at com.jogamp.opengl.GLProfile.getProfileMap(GLProfile.java:2324)
	at com.jogamp.opengl.GLProfile.get(GLProfile.java:1009)
	at com.jogamp.opengl.GLProfile.getGL2ES2(GLProfile.java:930)
	at processing.opengl.PSurfaceJOGL.initGL(PSurfaceJOGL.java:215)
	at processing.opengl.PSurfaceJOGL.initFrame(PSurfaceJOGL.java:149)
	at processing.core.PApplet.initSurface(PApplet.java:10369)
	at processing.core.PApplet.runSketch(PApplet.java:10277)
	at processing.core.PApplet.main(PApplet.java:10035)
InternalError: XXX0 profile[2]: GL2 -> profileImpl GL3bc !!! not mapped 


may this help

mrchris, I feel your pain. I’m stuck with processing-2 on my chromebook linux container. I wrote quite a bit for processing-3.5.3 and then it broke and I get the similar GL mapping errors that you get. If there’s a fix, I’d like to use it too.

coincidentally, I was using an RC flight simulator with an arduino interface for the transmitter over USB, called crrcsim. It worked great. I got a new update on the chromebook and now it won’t load the scenery so it just sits there stuck and flickering. crrcsim is written in c++ but it uses OpenGL and my theory is Google keeps screwing with something that affects OpenGL. It works great and then they “improve” it for some reason and break the very things you use or want. That’s actually been my experience with computers since the intel 286 days, glory or victory is not to be for longer than the next update.

I might just pack my bags, correction, might just take the clothes on my back, buy a rubber life raft and some basic gear and take to the sea. At least then my fate is truly up to me. Oh never mind, I’ve seen Castaway.

If you’re using Processing libs in a full Java IDE, then these were working on my Pixelbook a while back GitHub - codelerity/libp5x-examples: Examples using libp5x They use the LWJGL backend that’s in PraxisLIVE rather than JOGL.

Of course, Chromebooks being Chromebooks, might have broken since! :man_shrugging: :laughing:

For what it’s worth, I updated my Chromebook again but got rid of the linux beta. It runs Bullseye Debian version and it works again for now.

I have tiped :


in the Terminal and it worked for me.