Older versions of Processing

I have an older Mac that is running Java 1.4, and I want to try out Processing on it. How do I get the right version?

Hi! Have you tried the older versions found at https://processing.org/download/ ? The oldest version in that page is 1.5.1. Is that old enough?

That one says I need Java 1.5.

the releases go back

 on Aug 15, 2001
release-0003

often the [previous][next] buttons are not seen


???

now i can not speak about your operating system,
but usually processing comes with its own JAVA so i am not sure your question applies.
( like my sure more old Win 7 PC works perfect with newest processing 3.5.3
also i like the idea that you want (re)use old hardware still a other budget option
might be to buy a https://www.raspberrypi.org/products/ ,
)

also see


1 Like

Here is the specific message:

processingnotice

you mean? you get THAT when testing
processing 1.5.1 ?


Starting with Processing 2.1, we are no longer using Apple’s (deprecated) version of Java and have switched to the Oracle release.

that means my remark
that processing comes with its own JAVA
might be valid for OSX only from >= processing 2.1

1 Like

Yep, that message was with Processing 1.5.1.

I went back to the 0135 release of Processing and got that to work. It is on an old powerPC running OS 10.4.11 Tiger.

1 Like