New release of PiCrate for RaspberryPI

I have just released a new version (2.5.0) of PiCrate for the RaspberryPI, tested on RaspberryPI4 with both the latest RaspbianOS (32 bit) and ManjaroArm (64 bit) operating systems. Ideally you should install JRuby-9.3.0.0 (but does work with JRuby-9.2.19.0 the current default install on ManjaroArm).
See sketch run from Geany on RaspbianOS:-


The underlying java code is based on processing4 core, and uses release candidate versions of jogl-2.4.0 jars. Will also run on linux-x86_64, useful for development work. JRuby-9.3.0.0 approximates to vanilla ruby-2.6.8.

4 Likes