Kinect 2 for Processing

hello, I got a bit error when running Kinect 2 with my processing
here is the error message

‘ClassNotFoundException: KinectPV2.KinectPV2’

and here is the image of the error

I tried every single example code, way, method, code, SDK, and driver and didn’t get any results while it worked on my friend’s laptop from the first run!!!
plz someone helps

Hi @madtolla,

Have you properly installed the library in Processing with the Contribution Manager?
Are you importing the class correctly from the KinectPV2 package?
Have you ever installed another library that works when you import it? (eg Video)

hello, dude @josephh
sorry, but what is the Contribution Manager?
yes and I used the same way for my friend’s laptop
yes I installed another library like ‘Video’ but I am not sure if it works together with the Kinect code

1 Like

Sorry it wasn’t clear, the Contribution manager is when you go Sketch → Add a library → then install a library via the Processing utility.

So using the video library alone works right?

@josephh yeah it works

Ok try to uninstall / install it again if you not already did it.
Next if it doesn’t work try to uninstall Processing and install it again.

And finally post an issue on the Kinect 2 GitHub page: GitHub - ThomasLengeling/KinectPV2: Kinect4W 2.0 library for Processing