Gradle install fails

I installed AM and then automatically SDK is download. I choose to run an example on emulator and then automatically the phone system images is downloaded and installed as well as Intel HAXM. The Gradle build system starts to download but it fails to complete and APK is not generated. Is there anyway to download Gradle from other website?
Also I am curious whether after successful Gradle download, I can build without being online using Processing or I should be online to build a project?

what do you mean by

normally gradle is inside your mode folder ( with its jar… (and that is a way to answer the second part of your question: no, you dont need to be on line…)

I mean that the Processing starts to download the gradle build system from its repository and also from google developer but after successful download of approximately 50 components, the download of about 49 othe components isn’t success. Hence the build system won’t have all the required classes and components to build the APK file.

in this case either install manually the SDK, (downloading 24 then updating) or install android studio which will create its SDK, then go the preferences.txt from P5 and give the path to this SDK. Same problem here and now it works…

Thank you. The suggested process worked for me. First, I installed the Android Studio and let it download all the stuff. Then I redirected the Processing to use the installed SKD by AS.
Another question. I installed the whole package within a VMware VM. I can make the apk and transfer it to my android phone and its fine. But I want to run it in emulator but it fails. I read suggestions to replace standard x86 based AVD with an ARM one. But I don’t know workaround. I even tried to make a new emulator using AVD manager but I don’t have option to choose x86 image or ARM image.