GL Video library installing not working (Pi)

A noob question: I’m trying to install @gohai 's GL Video library on a Raspberry Pi, using the Contribution Manager in Processing. The install process gets stuck at ‘Installing’ (see photo), and can’t get out of it.

The ‘Installing’ state has persisted for over 2 hours. I’ve quit and restarted the computer several times, with the same result.

Raspbian NOOBS 2.8
Raspberry Pi 3, Model B

I’ve also set my Pi’s OpenGL to ‘Legacy’, as recommended in the readme file of GL Video.
I’ve noticed that the /home/pi/sketchbook/libraries folder contained a couple of ‘…tmp’ folders, which look to be previous stalled GL Video library downloads or installation attempts. I deleted these old ‘tmp’ folders, but there’s another one now due to my currently-stalled ‘Installing’ attempt.

Let me know if you have advice, thanks!

1 Like

tested here with
with updated RASPBIAN and Processing 3.5.3
no problem

1 Like

Thanks for replying, @kll.
I believe I also have the latest versions of Raspbian (Stretch ver. 9), and Processing 3.5.3. Still no luck though, still stuck ‘Installing’.

Update: I think I got it to work. The issue seemed to be available storage space on the Pi. I had gone down to close to zero available space, and after deleting some files, was able to install GL Video.