Game Control Plus library on MacBook Pro with M2 chip


I’m currently working on a program that uses processings ‘Game Control Plus’ library to enable user-interactions via a PS4/PS5 controller.

Recently, I upgraded my hardware to a MacBook Pro with M2 chip. Since then I’ve been facing difficulties in implementing the library and connecting the controller to my program.

Unfortunately I haven’t been able to find any solutions or discussions related to this specific issue online. I only found out that there will be no further updates on the library. So hopefully someone here has any solutions or ideas on workarounds to make the library compatible with newer devices.

I would appreciate any help, advice, or tips. Thanks!


as a workaround i will test with processing 3.5.4 to see if it work.
up to errors messages it looks for an apple silicon compiled library, 3.5.4 will use rosetta to use the intel version…
if you have the source of your library, may be it s possible to compile it for m2 (but im not good enough to tell if it is realistic or not)

i just tried the library on my apple m1 and it works without problems
so may be check your library installation
or post some code here if you want me to test it


thank you for your reply.

I successfully tested the library in processing 3.5.4. So this was a good idea.
Unfortunately the previous version doesn’t support the FX2D renderer, which I needed to implement for better performance. So this is not the actual solution for me in this specific case.

You mentioned in your edit that you tested the library on your m1 without problems. Do you mean the 3.5.4 version or the current version?

yes, i tried with processing 4.2
up to “manage libraries”, it is version 1.2.2 of game control plus
tell me if you need other test.